Smith & Wesson Forum

Go Back   Smith & Wesson Forum > >


Reply
 
Thread Tools Display Modes
  #1  
Old 08-11-2017, 10:52 PM
mp15spt2's Avatar
mp15spt2 mp15spt2 is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Aug 2017
Location: Free State of Virginia
Posts: 34
Likes: 1
Liked 10 Times in 8 Posts
Default Brand new sport2 not firing

Hello everyone, hoping someone can assist me with my brand new sport2.....it won't fire. Just brought it a few weeks ago and today took it to the range, loaded with the original mag with PPU brass. Pulled the charging handle and load, press the trigger and nothing.
Clear the rounds and tried again, nothing. Tried another Pmag magazine with same ammo and again nothing.

Am i doing something wrong?
Reply With Quote
  #2  
Old 08-11-2017, 11:04 PM
Pisgah Pisgah is offline
Member
Brand new sport2 not firing  
Join Date: Nov 2005
Location: Upstate SC
Posts: 1,820
Likes: 4
Liked 1,404 Times in 575 Posts
Default

You need to give a few more specifics than just "nothing". Exactly what are you saying? Are you sure a cartridge is being chambered fully? Does the hammer fall? Does the trigger not move at all? Are you sure the safety is fully in the fire position? Do the primers show any firing pin dent?
__________________
Pisgah
Reply With Quote
The Following User Likes This Post:
  #3  
Old 08-11-2017, 11:30 PM
mp15spt2's Avatar
mp15spt2 mp15spt2 is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Aug 2017
Location: Free State of Virginia
Posts: 34
Likes: 1
Liked 10 Times in 8 Posts
Default

I apology in advance for my ignorance, i am a newb to AR platform.

I verified there is a round chambered, safety is off and in Fire position. I do hear the hammer drop when trigger is squeezed, but no bang bang.
Reply With Quote
  #4  
Old 08-11-2017, 11:47 PM
TX-Dennis TX-Dennis is online now
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Mar 2014
Location: West Texas
Posts: 980
Likes: 1,662
Liked 998 Times in 510 Posts
Default

If you haven't already done so, I would take the bolt out and verify that there is a firing pin present. If so take the bolt apart and clean it. While it's apart check the firing pin to see if the tip is broken.

If you don't know how to disassemble the bolt look in your owner's manual or on youtube. The first time is a bit intimidating, but after that it is pretty simple.

Find a picture of an AR15 firing pin online and compare yours to it. Of course there could be other issues, but this is a good place to start.
__________________
Or something like that . . .

Last edited by TX-Dennis; 08-11-2017 at 11:49 PM.
Reply With Quote
The Following 2 Users Like Post:
  #5  
Old 08-12-2017, 12:07 AM
Ray1970's Avatar
Ray1970 Ray1970 is online now
Member
 
Join Date: Mar 2009
Location: Denver, CO
Posts: 558
Likes: 445
Liked 694 Times in 258 Posts
Default

Pull the bolt carrier assembly out and push the bolt back into the carrier. With the bolt back in the carrier you should be able to push the firing pin forward with your finger and see the tip of the pin protruding from the bolt face. It should stick out roughly .030".
Reply With Quote
  #6  
Old 08-12-2017, 12:13 AM
mp15spt2's Avatar
mp15spt2 mp15spt2 is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Aug 2017
Location: Free State of Virginia
Posts: 34
Likes: 1
Liked 10 Times in 8 Posts
Default

i pulled out the pin and it looked ok, not fractured, bent or broken, but when i push on the pin, i do not see it protruding out of the pin hole.
Reply With Quote
  #7  
Old 08-12-2017, 12:21 AM
Ray1970's Avatar
Ray1970 Ray1970 is online now
Member
 
Join Date: Mar 2009
Location: Denver, CO
Posts: 558
Likes: 445
Liked 694 Times in 258 Posts
Default

Quote:
Originally Posted by mp15spt2 View Post
i pulled out the pin and it looked ok, not fractured, bent or broken, but when i push on the pin, i do not see it protruding out of the pin hole.
Just to double check, you do have the bolt pushed rearward when you are checking? If the bolt is forward the pin won't protrude.
Reply With Quote
  #8  
Old 08-12-2017, 12:23 AM
mp15spt2's Avatar
mp15spt2 mp15spt2 is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Aug 2017
Location: Free State of Virginia
Posts: 34
Likes: 1
Liked 10 Times in 8 Posts
Default

Quote:
Originally Posted by Ray1970 View Post
Just to double check, you do have the bolt pushed rearward when you are checking? If the bolt is forward the pin won't protrude.
Yes the bolt was pushed rearward. I guess i can lube the bolt and pin to see if it will work, otherwise i'll give S&W a call tomorrow.

Last edited by mp15spt2; 08-12-2017 at 12:27 AM.
Reply With Quote
  #9  
Old 08-12-2017, 12:32 AM
Ray1970's Avatar
Ray1970 Ray1970 is online now
Member
 
Join Date: Mar 2009
Location: Denver, CO
Posts: 558
Likes: 445
Liked 694 Times in 258 Posts
Default

This might sound like a silly question, but the firing pin retainer (that little cotter pin looking thing) is where it's supposed to be?

I would pop one of my BCG's out and snap some pictures for you but I'm too lazy to go downstairs and open the safe.
Reply With Quote
  #10  
Old 08-12-2017, 12:37 AM
mp15spt2's Avatar
mp15spt2 mp15spt2 is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Aug 2017
Location: Free State of Virginia
Posts: 34
Likes: 1
Liked 10 Times in 8 Posts
Default

Quote:
Originally Posted by Ray1970 View Post
This might sound like a silly question, but the firing pin retainer (that little cotter pin looking thing) is where it's supposed to be?

I would pop one of my BCG's out and snap some pictures for you but I'm too lazy to go downstairs and open the safe.
i am not familiar where its supposed to be @, but it's pushed all the way in to lock the pin in place. I see a ridge @ the end of the pin, so i am assuming the pin is behind that ridge?
Reply With Quote
  #11  
Old 08-12-2017, 12:44 AM
Ray1970's Avatar
Ray1970 Ray1970 is online now
Member
 
Join Date: Mar 2009
Location: Denver, CO
Posts: 558
Likes: 445
Liked 694 Times in 258 Posts
Default

For lack of a better description, the retainer goes in that area between the "bulb" on the end of the pin and that large round shoulder just in front of it.

It's almost idiot proof. You just drop the pin in and then insert the retainer.

I have heard unconfirmed reports of people putting the retainer in first and then dropping the firing pin in behind it which won't let the firing pin move forward.

Should be plenty of videos on YouTube showing how to disassemble and reassemble the bolt carrier group if you have any doubts about whether it's right or not.
Reply With Quote
The Following User Likes This Post:
  #12  
Old 08-12-2017, 12:47 AM
mp15spt2's Avatar
mp15spt2 mp15spt2 is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Aug 2017
Location: Free State of Virginia
Posts: 34
Likes: 1
Liked 10 Times in 8 Posts
Default

yes, i dropped the pin in first then put the cotter pin in afterward. I am assuming it's in the right place because the firing pin is not dropping out?
Reply With Quote
  #13  
Old 08-12-2017, 12:51 AM
TX-Dennis TX-Dennis is online now
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Mar 2014
Location: West Texas
Posts: 980
Likes: 1,662
Liked 998 Times in 510 Posts
Default

You definitely should see the tip of the pin when you push it forward if the bolt is back. It sounds like something is amiss with either the pin, the bolt, or the bolt carrier. Call S&W. They will email you a shipping label to send it in for them to look at it.
__________________
Or something like that . . .
Reply With Quote
  #14  
Old 08-12-2017, 12:52 AM
TX-Dennis TX-Dennis is online now
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Mar 2014
Location: West Texas
Posts: 980
Likes: 1,662
Liked 998 Times in 510 Posts
Default

Quote:
Originally Posted by mp15spt2 View Post
yes, i dropped the pin in first then put the cotter pin in afterward. I am assuming it's in the right place because the firing pin is not dropping out?
Yes. Sounds like you are doing it right.
__________________
Or something like that . . .
Reply With Quote
  #15  
Old 08-12-2017, 01:08 AM
mp15spt2's Avatar
mp15spt2 mp15spt2 is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Aug 2017
Location: Free State of Virginia
Posts: 34
Likes: 1
Liked 10 Times in 8 Posts
Default

Quote:
Originally Posted by TX-Dennis View Post
You definitely should see the tip of the pin when you push it forward if the bolt is back. It sounds like something is amiss with either the pin, the bolt, or the bolt carrier. Call S&W. They will email you a shipping label to send it in for them to look at it.
This is my thought also. I will contact s&w tomorrow and see what they have to say. Thanks for all the help and i will report back when i get an answer or the problem fix.
Reply With Quote
  #16  
Old 08-12-2017, 07:43 AM
vonn's Avatar
vonn vonn is offline
US Veteran
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Sep 2011
Location: houston,texas
Posts: 4,931
Likes: 75,160
Liked 17,125 Times in 3,907 Posts
Default

Watch some videos on disassembly and reassembly to help you understand proper operation. Did any of the primers show any dimples? Is the hammer going all the way forward? Is the bolt going fully into battery?
__________________
Hue 68 noli me tangere
Reply With Quote
The Following User Likes This Post:
  #17  
Old 08-12-2017, 10:07 AM
mp15spt2's Avatar
mp15spt2 mp15spt2 is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Aug 2017
Location: Free State of Virginia
Posts: 34
Likes: 1
Liked 10 Times in 8 Posts
Default

Quote:
Originally Posted by vonn View Post
Watch some videos on disassembly and reassembly to help you understand proper operation. Did any of the primers show any dimples? Is the hammer going all the way forward? Is the bolt going fully into battery?
No i did not see any dimple on the primer. I'm guessing the pin is not hitting it. I'll lube it today and see what happens.
Reply With Quote
The Following User Likes This Post:
  #18  
Old 08-12-2017, 11:57 AM
JaxMike01 JaxMike01 is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Mar 2017
Posts: 70
Likes: 1
Liked 34 Times in 19 Posts
Default

Quote:
Originally Posted by vonn View Post
Watch some videos on disassembly and reassembly to help you understand proper operation. Did any of the primers show any dimples? Is the hammer going all the way forward? Is the bolt going fully into battery?


Sounds like it may not be going into battery as vonn mentions. Try hitting the forward assist a couple times.


Sent from my iPhone using Tapatalk
Reply With Quote
  #19  
Old 08-12-2017, 12:15 PM
505Gibbs's Avatar
505Gibbs 505Gibbs is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Aug 2007
Location: Suburban Deeeetroit
Posts: 997
Likes: 2
Liked 236 Times in 131 Posts
Default

Considering it 'should' have been proof checked by S&W yet it did not fire the first time you tried it sounds like its not fully seated as mentioned in the prior comments.

Good luck.
Reply With Quote
  #20  
Old 08-12-2017, 12:27 PM
MichiganScott MichiganScott is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Jan 2012
Location: God's Country
Posts: 4,335
Likes: 971
Liked 2,980 Times in 1,547 Posts
Default

Quote:
Originally Posted by vonn View Post
Watch some videos on disassembly and reassembly to help you understand proper operation. Did any of the primers show any dimples? Is the hammer going all the way forward? Is the bolt going fully into battery?
Pull the charging handle all the way to the back and let it fly forward without riding it. It sounds like the bolt's not going into battery.

I avoid using the forward assist. Their only use is when you ride the bolt forward in an attempt to be quiet like in a hunting situation. Other than that they usually only make a bad situation worse.
Reply With Quote
  #21  
Old 08-12-2017, 12:28 PM
mp15spt2's Avatar
mp15spt2 mp15spt2 is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Aug 2017
Location: Free State of Virginia
Posts: 34
Likes: 1
Liked 10 Times in 8 Posts
Default

Quote:
Originally Posted by JaxMike01 View Post
Sounds like it may not be going into battery as vonn mentions. Try hitting the forward assist a couple times.


Sent from my iPhone using Tapatalk
I did noticed a few time after pulling on the charging handle, the bolt show about 1/4 -1/2inch gap @ front of bolt and to barrel. What would cause this?
Reply With Quote
  #22  
Old 08-12-2017, 12:39 PM
JaxMike01 JaxMike01 is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Mar 2017
Posts: 70
Likes: 1
Liked 34 Times in 19 Posts
Default

It could be that you're riding the charging handle forward. When you pull the charging handle back release it and let it fly forward. If you have a small gap as you mentioned then that is your problem. It's not going fully into battery. If it still doesn't going to battery after releasing the charging handle and letting it fly back then there may be other issues. After you try charging it again and you still have a gap try hitting the forward assist a couple of times and it should going to battery then aim and pull the trigger.


Sent from my iPhone using Tapatalk
Reply With Quote
  #23  
Old 08-12-2017, 12:47 PM
mp15spt2's Avatar
mp15spt2 mp15spt2 is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Aug 2017
Location: Free State of Virginia
Posts: 34
Likes: 1
Liked 10 Times in 8 Posts
Default

Quote:
Originally Posted by JaxMike01 View Post
It could be that you're riding the charging handle forward. When you pull the charging handle back release it and let it fly forward. If you have a small gap as you mentioned then that is your problem. It's not going fully into battery. If it still doesn't going to battery after releasing the charging handle and letting it fly back then there may be other issues. After you try charging it again and you still have a gap try hitting the forward assist a couple of times and it should going to battery then aim and pull the trigger.


Sent from my iPhone using Tapatalk
pressing the forward assist does nothing for me, i have to manually take out the ammo and reload it then it will sit properly on the 2nd try.
Reply With Quote
  #24  
Old 08-12-2017, 01:14 PM
JaxMike01 JaxMike01 is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Mar 2017
Posts: 70
Likes: 1
Liked 34 Times in 19 Posts
Default

So at this point you have a banana Apple to get a single round fire through the weapon yet? If after charging the weapon and it still doesn't going to battery, and you still have the gap at the front of the carrier you may have issues the Smith and Wesson will have to iron out for you.



Sent from my iPhone using Tapatalk
Reply With Quote
  #25  
Old 08-12-2017, 01:22 PM
mp15spt2's Avatar
mp15spt2 mp15spt2 is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Aug 2017
Location: Free State of Virginia
Posts: 34
Likes: 1
Liked 10 Times in 8 Posts
Default

guess that i would have to do and contact s&w, just disappointed in a brand new rifle not firing, i own other s&w handguns and they all perform flawlessly with no issues, just my first rifle.
Reply With Quote
  #26  
Old 08-12-2017, 01:24 PM
mp15spt2's Avatar
mp15spt2 mp15spt2 is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Aug 2017
Location: Free State of Virginia
Posts: 34
Likes: 1
Liked 10 Times in 8 Posts
Default

think it may be the ammo? don't have other brand to test.
Reply With Quote
  #27  
Old 08-12-2017, 02:40 PM
mp15spt2's Avatar
mp15spt2 mp15spt2 is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Aug 2017
Location: Free State of Virginia
Posts: 34
Likes: 1
Liked 10 Times in 8 Posts
Default

Good news....i took out the bolt assembly, cleaned, lubed and now it fire like a champ. Thanks to all your assistant.
Reply With Quote
The Following User Likes This Post:
  #28  
Old 08-12-2017, 03:29 PM
mp15spt2's Avatar
mp15spt2 mp15spt2 is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Aug 2017
Location: Free State of Virginia
Posts: 34
Likes: 1
Liked 10 Times in 8 Posts
Default

and some more good news....just checked my mailbox and guess what came in..............guess??? ok, i'll tell you guys.....My CHP permit i am a happy camper.....Great Saturday, just awesome....
Reply With Quote
The Following User Likes This Post:
  #29  
Old 08-12-2017, 04:01 PM
JaxMike01 JaxMike01 is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Mar 2017
Posts: 70
Likes: 1
Liked 34 Times in 19 Posts
Default

Happy ending! Awesome.


Sent from my iPhone using Tapatalk
Reply With Quote
  #30  
Old 08-12-2017, 04:31 PM
mp15spt2's Avatar
mp15spt2 mp15spt2 is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Aug 2017
Location: Free State of Virginia
Posts: 34
Likes: 1
Liked 10 Times in 8 Posts
Default

Quote:
Originally Posted by JaxMike01 View Post
Happy ending! Awesome.


Sent from my iPhone using Tapatalk
Indeed, indeed.....anyway i used some synthetic Shell T6 motor oil to lube the gun....good idea or do you guys recommend something else?
Reply With Quote
The Following 2 Users Like Post:
  #31  
Old 08-12-2017, 05:48 PM
JaxMike01 JaxMike01 is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Mar 2017
Posts: 70
Likes: 1
Liked 34 Times in 19 Posts
Default

Quote:
Originally Posted by JaxMike01 View Post
So at this point you have a banana Apple to get a single round fire through the weapon yet?



Sent from my iPhone using Tapatalk
Just looking back through this thread and saw this. Lol
I would not suggest putting bananas or apples through your Sport, may be as targets...
Lesson... always check auto correct before posting.




Sent from my iPhone using Tapatalk
Reply With Quote
The Following User Likes This Post:
  #32  
Old 08-12-2017, 09:44 PM
vonn's Avatar
vonn vonn is offline
US Veteran
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Sep 2011
Location: houston,texas
Posts: 4,931
Likes: 75,160
Liked 17,125 Times in 3,907 Posts
Default

Nice to hear about a fix! I like to run all my semi auto weapons pretty wet until they are well broken in. Learned that from an old SFC on an M-60 and it hasn't failed me . Any oil is better than no oil and engine oil won't hurt a thing but you don't want it in the bore except as rust preventative and then dry it out before firing.
__________________
Hue 68 noli me tangere
Reply With Quote
  #33  
Old 08-12-2017, 09:53 PM
mp15spt2's Avatar
mp15spt2 mp15spt2 is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Aug 2017
Location: Free State of Virginia
Posts: 34
Likes: 1
Liked 10 Times in 8 Posts
Talking

Quote:
Originally Posted by vonn View Post
Nice to hear about a fix! I like to run all my semi auto weapons pretty wet until they are well broken in. Learned that from an old SFC on an M-60 and it hasn't failed me . Any oil is better than no oil and engine oil won't hurt a thing but you don't want it in the bore except as rust preventative and then dry it out before firing.

yeah i put a light coat on it and i'll clean it after a few hundreds round. It shoot pretty well and i like the recoil so far. I'm looking at adding a .300 upper later for the hunting seasons.
Reply With Quote
The Following User Likes This Post:
  #34  
Old 08-12-2017, 10:27 PM
Disabled1 Disabled1 is offline
Banned
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Apr 2015
Location: South Of The North Pole
Posts: 1,260
Likes: 491
Liked 705 Times in 425 Posts
Thumbs up

Quote:
Originally Posted by mp15spt2 View Post
Indeed, indeed.....anyway i used some synthetic Shell T6 motor oil to lube the gun....good idea or do you guys recommend something else?
That will do just fine. I usually use 3 IN 1 oil, or a mixture of MERCON V trans fluid and any synthetic oil.
Reply With Quote
  #35  
Old 08-12-2017, 11:02 PM
agksimon's Avatar
agksimon agksimon is online now
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Nov 2003
Location: Michigan, USA
Posts: 765
Likes: 170
Liked 222 Times in 141 Posts
Talking

Quote:
Originally Posted by Disabled1 View Post
or a mixture of MERCON V trans fluid and any synthetic oil.
Mercon is for automatic trannies. It will work on a SEMI-automatic too?

(This is tongue in cheek)
__________________
NRA R.S.O. & Life Member

Last edited by agksimon; 08-13-2017 at 08:36 AM.
Reply With Quote
The Following User Likes This Post:
  #36  
Old 08-13-2017, 08:30 AM
vonn's Avatar
vonn vonn is offline
US Veteran
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Sep 2011
Location: houston,texas
Posts: 4,931
Likes: 75,160
Liked 17,125 Times in 3,907 Posts
Default

A lot of manual 5 speeds run ATF as well. The additives in it should more than handle any conditions found in firearms and be a good rust preventative. A lot of people use a mix with other components to make a penatrating oil to free up the actions of old guns,I think they call it "Ed's red" but a search will give the recipes.
__________________
Hue 68 noli me tangere

Last edited by vonn; 08-13-2017 at 08:37 AM.
Reply With Quote
  #37  
Old 08-13-2017, 09:03 AM
mp15spt2's Avatar
mp15spt2 mp15spt2 is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Aug 2017
Location: Free State of Virginia
Posts: 34
Likes: 1
Liked 10 Times in 8 Posts
Default

so no 75w-90? I figured that T6 has protected my engine for 200+ thousandth miles so far, so it would be fine for the AR. I'll order some Hoppe in addition.
Reply With Quote
The Following User Likes This Post:
  #38  
Old 08-13-2017, 04:19 PM
Steelhat's Avatar
Steelhat Steelhat is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Jun 2013
Location: Southeast Texas
Posts: 162
Likes: 155
Liked 59 Times in 40 Posts
Default

I just stumbled over this thread. Glad you fixed your rifle. While I was reading I was about to ask if you cleaned and lubed it before you hit the range. Most manufacturers oil new guns with preservative oil which can be pretty thick in order to stay in place. Cleaning that out and re-lubing is the first thing I do to a new to me gun.
Reply With Quote
The Following User Likes This Post:
  #39  
Old 08-13-2017, 09:14 PM
TX-Dennis TX-Dennis is online now
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Mar 2014
Location: West Texas
Posts: 980
Likes: 1,662
Liked 998 Times in 510 Posts
Default

Glad you got it working!
__________________
Or something like that . . .
Reply With Quote
  #40  
Old 08-15-2017, 06:04 PM
mp15spt2's Avatar
mp15spt2 mp15spt2 is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Aug 2017
Location: Free State of Virginia
Posts: 34
Likes: 1
Liked 10 Times in 8 Posts
Default

Quote:
Originally Posted by Steelhat View Post
I just stumbled over this thread. Glad you fixed your rifle. While I was reading I was about to ask if you cleaned and lubed it before you hit the range. Most manufacturers oil new guns with preservative oil which can be pretty thick in order to stay in place. Cleaning that out and re-lubing is the first thing I do to a new to me gun.
unfortunately i did not clean or lube before use, i now know. I'd read everywhere, just take it out, load, shoot and have fun, but that wasn't the case for me. It's lubed now.
Reply With Quote
The Following 2 Users Like Post:
  #41  
Old 08-15-2017, 09:09 PM
Disabled1 Disabled1 is offline
Banned
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Apr 2015
Location: South Of The North Pole
Posts: 1,260
Likes: 491
Liked 705 Times in 425 Posts
Thumbs up

It's good to know you have it up and shooting. The Sport II is a great AR.
I learned my firearms cleaning and lube techniques from my grandfather. He was a very wise man.
Reply With Quote
  #42  
Old 08-25-2017, 02:19 PM
mp15spt2's Avatar
mp15spt2 mp15spt2 is offline
Member
Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing Brand new sport2 not firing  
Join Date: Aug 2017
Location: Free State of Virginia
Posts: 34
Likes: 1
Liked 10 Times in 8 Posts
Default

picked up a .300 BO, slap it on my MP15 lower and that upper is awesome
Reply With Quote
The Following User Likes This Post:
Reply

Thread Tools
Display Modes

Posting Rules
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to remove the front sling adapter from a new M&P15 Sport2??? highsideforum Smith & Wesson M&P15 Rifles 1 11-15-2016 12:44 AM
Adding Foregrip to a 100% stock Sport2: exact proven parts list and instructions? highsideforum Smith & Wesson M&P15 Rifles 22 11-15-2016 12:42 AM
Vortex Strike Eagle 1-6x24 Rifle Scope on Sport2? 1x front sight interference f/ CQB? highsideforum Smith & Wesson M&P15 Rifles 16 10-21-2016 09:12 PM
Firing pin issue brand new 686 Elmot S&W Revolvers: 1980 to the Present 11 12-07-2014 11:02 AM
Brand new model 632-2 sparks through firing pin hole when dry fired. Allen-frame S&W Revolvers: 1980 to the Present 8 10-19-2011 04:42 AM

Powered by vBadvanced CMPS v3.2.3
smith-wessonforum.com tested by Norton Internet Security smith-wessonforum.com tested by McAfee Internet Security

All times are GMT -4. The time now is 09:00 PM.


S-W Forum, LLC 2000-2015
Smith-WessonForum.com is not affiliated with Smith & Wesson Holding Corporation (NASDAQ Global Select: SWHC)