Smith & Wesson Forum

Go Back   Smith & Wesson Forum > >


Reply
 
Thread Tools Display Modes
  #1  
Old 03-04-2018, 10:16 PM
Mzuri Mzuri is offline
Member
M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds  
Join Date: Jun 2017
Posts: 101
Likes: 31
Liked 129 Times in 40 Posts
Default M&P 15 SP2 misfeeds

On Monday I bought my first S&W product that was not a pre- lock revolver. It was a Sport II, about which I have heard nothing but good things. I got it to the range today and was disappointed. Despite trying three different types of magazines, four different types of ammo, giving at a thorough cleaning, and swapping out the lower for a borrowed very nice Bravo Company lower with a Giesele trigger, which I now covet, it could hardly get through ten rounds without a misfeed. When this happened it would usually eject the fired round, strip a round from the mag and get the new round about 80% of the way in the chamber but not quite go fully into battery. Occasionally I could sort of fiddle with the charging handle and it would go into battery, but then it would not be cocked. The rounds that did not go into battery were bent as if someone with strong fingers had used his thumb to push the bullet about 5-10 degrees of of plumb. This also left a dimple in the case neck. Brass that went into battery, was fired and extracted had distinctive scrapping marks on one side of the case. I think I am going to send it to Smith, but does anyone have any idea what might be going on?
Reply With Quote
The Following 2 Users Like Post:
  #2  
Old 03-04-2018, 10:31 PM
cyphertext cyphertext is offline
US Veteran
M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds  
Join Date: Feb 2012
Location: Wylie, TX
Posts: 4,256
Likes: 949
Liked 3,297 Times in 1,809 Posts
Default

Send it in... every time someone has had this issue, the bolt carrier group has been replaced by S&W.
Reply With Quote
The Following 5 Users Like Post:
  #3  
Old 03-05-2018, 12:06 AM
RBS_@63 RBS_@63 is offline
Member
M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds  
Join Date: Feb 2018
Posts: 9
Likes: 1
Liked 14 Times in 5 Posts
Default

I only have put 80rds through mine and it has done this 2 times on me also. I'm hoping that this was a ammo issue and not something else. I will put some more rounds down range and see if it happens again.
Reply With Quote
  #4  
Old 03-05-2018, 08:01 AM
MichiganScott MichiganScott is offline
Member
M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds  
Join Date: Jan 2012
Location: God's Country
Posts: 4,656
Likes: 1,172
Liked 3,404 Times in 1,732 Posts
Default

It could simply be lack of lubrication or bad ammo, but your best bet is to call S&W and get a call tag to send it in on their dime.
Reply With Quote
The Following User Likes This Post:
  #5  
Old 03-09-2018, 11:19 PM
Tinhack's Avatar
Tinhack Tinhack is offline
Member
M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds  
Join Date: Nov 2016
Location: South Texas
Posts: 329
Likes: 228
Liked 391 Times in 172 Posts
Default

On mine it was the left feed ramp causing jams and bent rounds. The rounds showed significant scratching on the bullets. If you're not able to do gun smithing yourself, send it back to S&W.
Attached Thumbnails
M&P 15 SP2 misfeeds-bullet-3-extra-jpg   M&P 15 SP2 misfeeds-bullet-4-extra-jpg  
__________________
Si vis pacem para bellum.
Reply With Quote
  #6  
Old 04-13-2018, 03:15 PM
Mzuri Mzuri is offline
Member
M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds  
Join Date: Jun 2017
Posts: 101
Likes: 31
Liked 129 Times in 40 Posts
Default

Quote:
Originally Posted by cyphertext View Post
Send it in... every time someone has had this issue, the bolt carrier group has been replaced by S&W.
Good call. I just got it back from S&W. According to the accompanying paper work they replaced the bolt, but it looks like the entire bcg may have been replaced. Whatever they did the rifle, which previously could not get through a mag without several misfeeds, worked flawlessly today.

This is my second really positive experience with S&W's customer service.
Reply With Quote
The Following 2 Users Like Post:
  #7  
Old 04-13-2018, 04:39 PM
Rastoff's Avatar
Rastoff Rastoff is offline
Member
M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds  
Join Date: Dec 2011
Location: So Cal (Near Edwards AFB)
Posts: 13,062
Likes: 2,132
Liked 13,242 Times in 5,253 Posts
Default

Glad you got it fixed. The Sport II is their economy rifle and I'm not surprised to hear of issues now and then. Even so, they have a great warranty and good service.

I look forward to hearing about many more happy rounds from yours.


EDIT to add:
That Geissele trigger is nice, but check out this one: POF AR15/AR10 4.5lb Trigger w/ KNS Anti Rotation Pins
It's easier to install and on sale now for $135. I have one and they're amazing.
__________________
Freedom isn't free.

Last edited by Rastoff; 04-13-2018 at 04:41 PM.
Reply With Quote
The Following User Likes This Post:
  #8  
Old 04-14-2018, 05:11 PM
fyimo's Avatar
fyimo fyimo is offline
Member
M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds  
Join Date: Jan 2009
Location: Arkansas
Posts: 18,611
Likes: 5,839
Liked 5,494 Times in 1,912 Posts
Talking

When I bought my S&W Sport II it didn't even fire the first round without locking up and failing to fire. I called S&W and shipped it in and they replaced the entire upper and since then it has been flawless. I assume it was head space issue but they fixed it really quickly and I couldn't have been happier.
Reply With Quote
  #9  
Old 04-15-2018, 09:24 AM
blues7's Avatar
blues7 blues7 is offline
Member
M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds M&P 15 SP2 misfeeds  
Join Date: Dec 2015
Location: Blue Ridge Mtns
Posts: 1,344
Likes: 845
Liked 2,608 Times in 856 Posts
Default

Had similar trouble to the OP on the very first round fired a couple years back. Sent to S&W and the bolt (and maybe the BCG) was replaced. Mine is the "TS" model.
__________________
3" 686+, 642-1, M&P15 TS
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting a lot of misfeeds stev32k Smith & Wesson SD & Sigma Pistols 29 11-08-2012 07:28 PM

Powered by vBadvanced CMPS v3.2.3
smith-wessonforum.com tested by Norton Internet Security smith-wessonforum.com tested by McAfee Internet Security

All times are GMT -4. The time now is 06:58 AM.


Search Engine Optimisation provided by DragonByte SEO v2.0.42 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
S-W Forum, LLC 2000-2018
Smith-WessonForum.com is not affiliated with Smith & Wesson Holding Corporation (NASDAQ Global Select: SWHC)