Smith & Wesson Forum

Go Back   Smith & Wesson Forum > >


Reply
 
Thread Tools Display Modes
  #1  
Old 03-06-2016, 02:13 AM
pistol_pete pistol_pete is offline
Member
installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues?  
Join Date: Mar 2016
Posts: 6
Likes: 0
Liked 5 Times in 3 Posts
Default installed apex springs, now having trigger reset issues?

I recently installed the apex striker spring and trigger spring (but not the apex trigger). Immediately after installing I played around with dry firing with some snap caps and manually cycling them with no issues. This morning I took it to the range and found that about every 2 or 3 shots, the casing would eject normally and the next round would feed as it should, but when I pull the trigger... nothing. I would then rack the slide, eject the unfired round, and the next one would fire normally. I assume this is a trigger reset issue, but I'm no expert. I didn't have this problem at all before. I would really appreciate any advice or insight as to what may be causing this and whether or not I need to reinstall the factory trigger spring.

Thank you!
Reply With Quote
The Following User Likes This Post:
  #2  
Old 03-06-2016, 03:19 AM
ou1954's Avatar
ou1954 ou1954 is offline
Member
installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues?  
Join Date: Dec 2014
Location: Oklahoma
Posts: 951
Likes: 682
Liked 297 Times in 210 Posts
Default No fire

Quote:
Originally Posted by pistol_pete View Post
I recently installed the apex striker spring and trigger spring (but not the apex trigger). Immediately after installing I played around with dry firing with some snap caps and manually cycling them with no issues. This morning I took it to the range and found that about every 2 or 3 shots, the casing would eject normally and the next round would feed as it should, but when I pull the trigger... nothing. I would then rack the slide, eject the unfired round, and the next one would fire normally. I assume this is a trigger reset issue, but I'm no expert. I didn't have this problem at all before. I would really appreciate any advice or insight as to what may be causing this and whether or not I need to reinstall the factory trigger spring.

Thank you!
Snap caps still behave correctly?

In live fire, did you feel the reset?

My very first time out with a brand new SD9VE I was at an outdoor range with metal "ping" targets. I decided to be fancy and pull some (for me) rapid fire, just for fun. Sometimes, no-fire.

I quickly found I wasn't releasing the trigger past reset. Stupid but true.
Reply With Quote
  #3  
Old 03-06-2016, 08:02 AM
pistol_pete pistol_pete is offline
Member
installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues?  
Join Date: Mar 2016
Posts: 6
Likes: 0
Liked 5 Times in 3 Posts
Default

Quote:
Originally Posted by ou1954 View Post
Snap caps still behave correctly?

In live fire, did you feel the reset?

My very first time out with a brand new SD9VE I was at an outdoor range with metal "ping" targets. I decided to be fancy and pull some (for me) rapid fire, just for fun. Sometimes, no-fire.

I quickly found I wasn't releasing the trigger past reset. Stupid but true.
Snap caps behave perfectly.

Honestly, I don't even know exactly what the reset should feel like. I had been to the range with it twice before changing the springs and put maybe 200 rounds through it with absolutely no problems. Not a single failure.

Shooting yesterday after changing the springs, I tried to experiment with how quickly and completely I released the trigger after shooting. I tried holding it down for a full second after a shot, quickly slapping at it without holding at all, and everything in between. It didn't seem to have any affect.
Reply With Quote
  #4  
Old 03-06-2016, 03:42 PM
Dr Denby Dr Denby is offline
Member
installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues?  
Join Date: May 2015
Posts: 210
Likes: 2
Liked 117 Times in 83 Posts
Default

Hi Pete.

The reset should feel sharp and crisp and manually cycling, should occur within an inch or so of pulling back on the slide.

The spring is not in fully properly.

Disassemble and try again and once in properly, it will work perfectly.

Doc
Reply With Quote
The Following User Likes This Post:
  #5  
Old 03-06-2016, 06:44 PM
pistol_pete pistol_pete is offline
Member
installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues?  
Join Date: Mar 2016
Posts: 6
Likes: 0
Liked 5 Times in 3 Posts
Default

Quote:
Originally Posted by Dr Denby View Post
Hi Pete.

The reset should feel sharp and crisp and manually cycling, should occur within an inch or so of pulling back on the slide.

The spring is not in fully properly.

Disassemble and try again and once in properly, it will work perfectly.

Doc
I definitely feel that when I manually cycle. I can't say I feel it when firing live rounds, though, even before the apex springs. I followed along with apex tactical's installation video and felt like I did everything the way they did it, but I'll give it another shot. Would it be the trigger spring specifically, or should I just retry all 3 springs?

I just opened everything up to take a look. I didn't even consider until now that I had also removed the spring in the sear housing block, so I put that back just in case. I checked the striker spring and I can't imagine how I could've gotten that one wrong, everything looks pretty good. The trigger spring is where it's supposed to be, the only thing I can think of is that maybe I hooked the back part on wrong? The opening faces up toward the slide.

Thanks for your help! I'll get to the range tomorrow to give it a try.

Last edited by pistol_pete; 03-06-2016 at 07:51 PM.
Reply With Quote
  #6  
Old 03-06-2016, 08:03 PM
AnthemBassMan AnthemBassMan is offline
Member
installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues?  
Join Date: Feb 2014
Location: Tuscarawas County, Ohio!
Posts: 419
Likes: 391
Liked 219 Times in 145 Posts
Default

Yes, the open end of the trigger return spring faces upwards when you have the pin back in. Apex doesn't recommend removing the sear spring. That may or may not cause the issue. Galloway has a replacement spring in their kit, but there's still one in the seat block when everything is out back together.

L8R,
Matt
__________________
SD40-VE owner and proud of it!
Reply With Quote
  #7  
Old 03-06-2016, 08:24 PM
pistol_pete pistol_pete is offline
Member
installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues?  
Join Date: Mar 2016
Posts: 6
Likes: 0
Liked 5 Times in 3 Posts
Default

Quote:
Originally Posted by AnthemBassMan View Post
Yes, the open end of the trigger return spring faces upwards when you have the pin back in. Apex doesn't recommend removing the sear spring. That may or may not cause the issue. Galloway has a replacement spring in their kit, but there's still one in the seat block when everything is out back together.

L8R,
Matt
I'm hoping that was the issue because as far as I can tell everything is installed as it should be. If not, I guess the next step will be to change the other springs back to factory one at a time and see if that does it.
Reply With Quote
  #8  
Old 03-09-2016, 06:55 PM
pistol_pete pistol_pete is offline
Member
installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues?  
Join Date: Mar 2016
Posts: 6
Likes: 0
Liked 5 Times in 3 Posts
Default

The sear spring was apparently the problem. I put it back everything is working great.
Reply With Quote
The Following User Likes This Post:
  #9  
Old 03-17-2016, 07:17 AM
stanmondz stanmondz is offline
Member
installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues?  
Join Date: Apr 2015
Posts: 56
Likes: 1
Liked 10 Times in 8 Posts
Default

mine would stick as the gun got dirty.i ended up putting the factory return spring back in
Reply With Quote
The Following User Likes This Post:
  #10  
Old 03-19-2016, 11:12 AM
jamestam jamestam is offline
Member
installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues?  
Join Date: Mar 2016
Location: Massachusetts
Posts: 1
Likes: 0
Liked 0 Times in 0 Posts
Default

I am getting light strikes with my SD9VE since installing the spring kit. The rounds would always fire when I tried using them a second time. Could it be the new ammo I just purchased?
Reply With Quote
  #11  
Old 03-21-2016, 02:39 PM
Balenti Balenti is offline
Member
installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues?  
Join Date: Mar 2016
Posts: 1
Likes: 1
Liked 0 Times in 0 Posts
Default Striker issues

Quote:
Originally Posted by pistol_pete View Post
I recently installed the apex striker spring and trigger spring (but not the apex trigger). Immediately after installing I played around with dry firing with some snap caps and manually cycling them with no issues. This morning I took it to the range and found that about every 2 or 3 shots, the casing would eject normally and the next round would feed as it should, but when I pull the trigger... nothing. I would then rack the slide, eject the unfired round, and the next one would fire normally. I assume this is a trigger reset issue, but I'm no expert. I didn't have this problem at all before. I would really appreciate any advice or insight as to what may be causing this and whether or not I need to reinstall the factory trigger spring.

Thank you!
I had an apex trigger put in mine and the exact same thin happened to me. The guy who did the job thinks I'm crazy and shooting the gun wrong.
Reply With Quote
  #12  
Old 05-06-2017, 08:28 AM
SWSD9ve SWSD9ve is offline
Member
installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues?  
Join Date: Oct 2016
Posts: 6
Likes: 1
Liked 0 Times in 0 Posts
Default

Quote:
Originally Posted by pistol_pete View Post
I recently installed the apex striker spring and trigger spring (but not the apex trigger). Immediately after installing I played around with dry firing with some snap caps and manually cycling them with no issues. This morning I took it to the range and found that about every 2 or 3 shots, the casing would eject normally and the next round would feed as it should, but when I pull the trigger... nothing. I would then rack the slide, eject the unfired round, and the next one would fire normally. I assume this is a trigger reset issue, but I'm no expert. I didn't have this problem at all before. I would really appreciate any advice or insight as to what may be causing this and whether or not I need to reinstall the factory trigger spring.

Thank you!
I also installed the Apex SD Spring Kit and the Galloway Precision Sear Spring in my SD9ve. I had the same failure experience. The first 100 rounds had about a 10% failure rate. I was using a 200-round box of Winchester White Box. I then reinstalled the original S&W factory sear spring. Ran the second 100 rounds from the Winchester White Box resulting in about a 10% failure rate. So, I reinstalled the Galloway Precision Sear Spring and changed ammo. 300 rounds so far with zero failures. 200 rounds of Perfecta and 100 rounds of TulAmmo. At least in my case it appears that the problem was with the ammo and not the springs. The trigger pull is down from 8 pounds to 4 .
Reply With Quote
  #13  
Old 06-20-2018, 03:44 PM
nicalex nicalex is offline
Member
installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues?  
Join Date: May 2018
Location: Georgia
Posts: 18
Likes: 3
Liked 0 Times in 0 Posts
Default

Quote:
Originally Posted by pistol_pete View Post
I recently installed the apex striker spring and trigger spring (but not the apex trigger). Immediately after installing I played around with dry firing with some snap caps and manually cycling them with no issues. This morning I took it to the range and found that about every 2 or 3 shots, the casing would eject normally and the next round would feed as it should, but when I pull the trigger... nothing. I would then rack the slide, eject the unfired round, and the next one would fire normally. I assume this is a trigger reset issue, but I'm no expert. I didn't have this problem at all before. I would really appreciate any advice or insight as to what may be causing this and whether or not I need to reinstall the factory trigger spring.

Thank you!
Sounds like ammo issue. Are they reloads?
Reply With Quote
  #14  
Old 06-20-2018, 03:47 PM
nicalex nicalex is offline
Member
installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues?  
Join Date: May 2018
Location: Georgia
Posts: 18
Likes: 3
Liked 0 Times in 0 Posts
Default

Quote:
Originally Posted by pistol_pete View Post
I recently installed the apex striker spring and trigger spring (but not the apex trigger). Immediately after installing I played around with dry firing with some snap caps and manually cycling them with no issues. This morning I took it to the range and found that about every 2 or 3 shots, the casing would eject normally and the next round would feed as it should, but when I pull the trigger... nothing. I would then rack the slide, eject the unfired round, and the next one would fire normally. I assume this is a trigger reset issue, but I'm no expert. I didn't have this problem at all before. I would really appreciate any advice or insight as to what may be causing this and whether or not I need to reinstall the factory trigger spring.

Thank you!
someone mentioned the sere spring and that could very well be the problem
Reply With Quote
  #15  
Old 06-20-2018, 08:13 PM
garddogg56's Avatar
garddogg56 garddogg56 is offline
Member
installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues?  
Join Date: Dec 2015
Location: Maine
Posts: 578
Likes: 1,199
Liked 701 Times in 291 Posts
Default

I like keeping them the way the engineers design them for......
Reply With Quote
The Following User Likes This Post:
  #16  
Old 06-20-2018, 11:25 PM
Dangerman Dangerman is offline
Member
installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues?  
Join Date: Jul 2016
Posts: 8
Likes: 0
Liked 5 Times in 4 Posts
Default

isnt the reason galloway came out with the quick sear was to work in conjunction with the lighter springs? I have never messed with the springs .... just smoothing rough areas.... but I like the weight in the 7-10 pound range on triggers. If I was dead set on lightening the trigger I would give them a call on that quick sear they offer.

These triggers are not really that heavy. VP70z... Patriot 45...Colt 2000 etc. ......stay away from those if the trigger bothers you on Sigmas. I grew up on airpistols and double action revolvers so the sigma triggers are fine for me.

If it does bother you though.... by all means do something about it. I dont see anything wrong with mods to tailor a gun to the shooter. Its been done since guns were invented. Sigmas/SDs have rough edges and are made for fast, cheap, and efficient mass production. Fortunately we live in a time when aftermarket provides a lot of options. They are very good pistols as they are but do benefit from some tweeking for some shooters. Why not? Some people want a little more than just something that goes bang.
Reply With Quote
The Following User Likes This Post:
  #17  
Old 07-16-2018, 05:12 PM
3hounds 3hounds is offline
Member
installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues? installed apex springs, now having trigger reset issues?  
Join Date: Dec 2012
Location: PA.
Posts: 592
Likes: 423
Liked 115 Times in 88 Posts
Default

My trigger in my SD40VE is NOTHING LIKE IT WAS ORIGINALLY, a lot of polishing, bending, deburring, adding epoxy in places, ect.... NO MORE LONG, GRITTY, 10 LB TRIGGER PULL FOR ME. It's right at 4 lbs. ( could go to about 2lbs. but it's defense gun with really no safety) & very very smooth but it took a lot of thinking, time, mistakes, some money for certain tools, supplies & knowledge. Everything is stock also, I went the lighter spring route, that was 1 mistake, so was the steel guide rod till I got the correct length spring for it. The 9mm shield I also carry is bone stock except for polishing, that trigger I like.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
m&p compact 9mm apex trigger kit installed pickupman250 GUNS - For Sale or Trade 0 05-23-2015 08:02 AM
Installed my Apex Shield AET trigger. SpringGunTunes Smith & Wesson M&P Pistols 3 02-26-2014 08:27 PM
Apex FSS Poly Trigger Kit Installed oligoodday Smith & Wesson M&P Pistols 11 01-14-2014 08:08 PM
Apex kit and apex trigger installed BennyS Smith & Wesson M&P Pistols 4 12-23-2013 09:44 AM
Apex trigger installed on 9mm norsmis Smith & Wesson M&P Pistols 8 01-29-2013 08:33 AM

Powered by vBadvanced CMPS v3.2.3
smith-wessonforum.com tested by Norton Internet Security smith-wessonforum.com tested by McAfee Internet Security

All times are GMT -4. The time now is 09:33 PM.


Search Engine Optimisation provided by DragonByte SEO v2.0.42 (Pro) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
S-W Forum, LLC 2000-2018
Smith-WessonForum.com is not affiliated with Smith & Wesson Holding Corporation (NASDAQ Global Select: SWHC)